Transaction Screening Issues

Incident Report for Unit21 Multitenant EU-Prod1

Resolved

This issue has been resolved. Thank you for your patience.
Posted Jul 14, 2026 - 22:22 UTC

Investigating

We are currently investigating issues with the transaction screening endpoint.
Posted Jul 14, 2026 - 22:14 UTC
This incident affected: Real Time Payments Screening.