LexisNexis Watchlist Screening Issue

Incident Report for Unit21 Multitenant EU-Prod1

Resolved

This incident has been resolved. Please note that all failures to enroll in ongoing monitoring will get retried in the next batch run. Thank you for your patience.
Posted Jul 14, 2026 - 17:35 UTC

Identified

We have identified that watchlist screening offered by LexisNexis were failing from 8:26AM PT. Our team is continuing to monitor this issue.
LexisNexis incident page: https://status.risknarrative.cloud/
Posted Jul 14, 2026 - 16:30 UTC
This incident affected: Case Management.